Yealink SIP T4 (U) Series

    Yealink SIP T4 (U) Series

    Brand: Yealink

    €141.16 incl. VAT

    In stock

    Yealink SIP T42U. Product type: IP Phone, Product colour: Grey, Handset type: Wireless handset. Phonebook capacity: 1000 entries. Display: LCD, Display diagonal: 6.86 cm (2.7"), Display resolution: 192 x 68 pixels. Ethernet LAN interface type: Gigabit Ethernet, Supported network protocols: IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263), Security algorithms: 256-bit AES, HTTPS, TLS, WPA2, WPA3. Power consumption (typical): 2.2 W Sound and Hear with Remarkable Clarity Yealink Optima HD Voice technology combines cutting-edge hardware and software with wideband technology…

    Key facts about Yealink SIP T4 (U) Series
    BrandYealink
    CategoryPhones & Telephony
    SKU1301201
    Price€141.16 incl. 21% VAT
    AvailabilityIn stock
    ConditionNew
    Sold byVenture Trade SIA, Rīga, Latvia (reg. 40203623323, VAT LV40203623323)
    Delivery€7.99 across the EU, free over €100 · dispatched within 1 working day
    Returns14-day free returns